Cloudflare + Render gives 404 error


I am trying to connect the domain piñ (from to my server via Cloudflare DNS.

I followed the Cloudflare instructions url and it seems to be all good:

But page still not loading and showing a 404. When I go to www.piñ the redirect works well. In the network tab says Cloudflare made a redirect.

Also my domain nameservers are pointing to Cloudflare:

➜  ~ nslookup -q=ns

Non-authoritative answer:	nameserver =	nameserver =

Authoritative answers can be found from:

DNS checker shows everything is ok with the root domain:

As context, piñ is an API and now the only path working is /tracking/{SOME_CODE}

I tried everything and nothing works. Please help!

Looking at the response, I have a feeling the 404 is coming from your service - can you check your service log output to see if the 404 is making it there, if it is, then it’s a genuine 404 and being raised by your application.

John B

At the same time I have correct responses from onrender host:

using the domain doesn’t work for the same request

@John_B sorry for bothering you. Any ideas on this?


Now it works recreating the app. For sure it was related to the incident.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.