Unable to create new service for private repository

When selecting a repository for a new service, pasting the link of a private repository and selecting it results in a blank screen.

This is due the fact that Render doesn’t have permission to access the repository you’re selecting. Usually this is because you previously gave Render access to specific repositories and you’re now trying to create a service for a new one. In order to resolve this:

  1. Go to your account settings page and disconnect your Github account

  2. Click New + at the top of the dashboard and choose one of the options

  3. From the repo selection screen, click the link to connect your Github or Gitlab account

  4. Select the repositories you’d like to give Render access to (or give access to all repositories if you’d like to prevent this from occurring the next time you add a new repository). Be sure to also select the repos for your existing Render services, otherwise subsequent builds will fail.

You should now be able to create a new service for the selected repository.

I understand this isn’t an ideal workflow when adding new repositories. We have an open issue internally to improve the user experience for this case.