ERROR: Could not find a version that satisfies the requirement

Hi!

I’m trying to deploy a flask application, and so I needed the render web-service to run my packages through requirements.txt. But during deployment, I keep getting errors for packages unable to find the latest version. For the example here, I know a 1.23.4 numpy package exists, but the render web service doesn’t seem to be able to find it? The most recent one it’s showing me is 1.21.6

How do I fix this? And what is causing this?

My build command looks like this (python -m pip install --upgrade pip && pip install -r requirements.txt)

Thank you for the help in advance!!!

Dec 16 04:41:03 PM  ERROR: Could not find a version that satisfies the requirement numpy==1.23.4 (from versions: 1.3.0, 1.4.1, 1.5.0, 1.5.1, 1.6.0, 1.6.1, 1.6.2, 1.7.0, 1.7.1, 1.7.2, 1.8.0, 1.8.1, 1.8.2, 1.9.0, 1.9.1, 1.9.2, 1.9.3, 1.10.0.post2, 1.10.1, 1.10.2, 1.10.4, 1.11.0, 1.11.1, 1.11.2, 1.11.3, 1.12.0, 1.12.1, 1.13.0rc1, 1.13.0rc2, 1.13.0, 1.13.1, 1.13.3, 1.14.0rc1, 1.14.0, 1.14.1, 1.14.2, 1.14.3, 1.14.4, 1.14.5, 1.14.6, 1.15.0rc1, 1.15.0rc2, 1.15.0, 1.15.1, 1.15.2, 1.15.3, 1.15.4, 1.16.0rc1, 1.16.0rc2, 1.16.0, 1.16.1, 1.16.2, 1.16.3, 1.16.4, 1.16.5, 1.16.6, 1.17.0rc1, 1.17.0rc2, 1.17.0, 1.17.1, 1.17.2, 1.17.3, 1.17.4, 1.17.5, 1.18.0rc1, 1.18.0, 1.18.1, 1.18.2, 1.18.3, 1.18.4, 1.18.5, 1.19.0rc1, 1.19.0rc2, 1.19.0, 1.19.1, 1.19.2, 1.19.3, 1.19.4, 1.19.5, 1.20.0rc1, 1.20.0rc2, 1.20.0, 1.20.1, 1.20.2, 1.20.3, 1.21.0rc1, 1.21.0rc2, 1.21.0, 1.21.1, 1.21.2, 1.21.3, 1.21.4, 1.21.5, 1.21.6)
Dec 16 04:41:03 PM  ERROR: No matching distribution found for numpy==1.23.4

Hey,

Thanks for reaching out!

Please check your Python version. Support for Python 3.7 is dropped since Numpy 1.22.0 release.

Here’s how to specify Python version in Render: https://render.com/docs/python-version

Jérémy, Render Support

Thanks for the response!

I’m not quite sure how to do this and I’m struggling to find the answer to this online :

you can customize the Python version for your app by setting the PYTHON_VERSION environment variable to a valid Python version, for example 3.8.2

Do I include this somehow in my requirements file? Or is this done in Render’s build command area?

Thank you!

This was able to help me. I wish this was better specified on the render docs (Specifying a Python Version | Render). I think if this was better reflected on the docs it would be better for others in the future who run into this issue :slight_smile:

That’s a good call, we should probably improve this page. I’ve forwarded your feedback to our documentation team.

Jérémy, Render Support

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.