Deployment Error: Could not find a version that satisfies the requirement

I’m having trouble deploying the Python-Flask API due to a deployment error.


Jul 31 01:17:33 PM    Downloading distro-1.7.0-py3-none-any.whl (20 kB)
Jul 31 01:17:33 PM  ERROR: Could not find a version that satisfies the requirement distro-info===1.1build1 (from versions: 0.10, 1.0)
Jul 31 01:17:33 PM  ERROR: No matching distribution found for distr
Jul 31 01:17:33 PM  ==> Build failed 😞

Note that:
I have set the PYTHON_VERSION to 3.10.6
Also my build command is : python -m pip install --upgrade pip && pip install -r requirements.txt

Have spent a lot of time on this but still not been able to figure out.
Any help is highly appreciated. Thanks.

distro-info 1.1build1 doesn’t exist, distro-info · PyPI

Change distro to be 1.8.0 instead of 1.7.0?

Thanks Jason,
I changed the distro to 1.8.0 and it didn’t work.
So I changed the distro-info to 1.0

And then it threw the following error

Jul 31 06:14:38 PM    Downloading distro-1.8.0-py3-none-any.whl (20 kB)
Jul 31 06:14:38 PM  Collecting distro-info===1.0 (from -r requirements.txt (line 18))
Jul 31 06:14:38 PM    Downloading distro_info-1.0-py3-none-any.whl (4.0 kB)
Jul 31 06:14:38 PM  ERROR: Could not find a version that satisfies the requirement duplicity==0.8.21 (from versions:,,,,,,,,,,,,,,,,,,,, 0.8.13.dev11, 0.8.13.dev12, 0.8.13.dev18, 0.8.13, 0.8.14.dev7, 0.8.14.dev9, 0.8.14.dev12, 0.8.14.dev15, 0.8.14.dev18, 0.8.14.dev25, 0.8.14.dev26, 0.8.14.dev27, 0.8.14.dev49, 0.8.14.dev61, 0.8.14.dev64, 0.8.14, 0.8.15.dev4, 0.8.15.dev9, 0.8.15.dev13, 0.8.15.dev25, 0.8.15, 0.8.16.dev2, 0.8.16.dev12, 0.8.16.dev17, 0.8.16.dev25, 0.8.16.dev32, 0.8.16, 0.8.17.dev2, 0.8.17.dev3, 0.8.17.dev8, 0.8.17.dev15, 0.8.17.dev18, 0.8.17.dev20, 0.8.17.dev22, 0.8.17.dev24, 0.8.17.dev27, 0.8.17.dev29, 0.8.17.dev32, 0.8.17.dev33, 0.8.17.dev35, 0.8.17.dev37, 0.8.17.dev39, 0.8.17, 0.8.18.dev9, 0.8.18.dev10, 0.8.18.dev11, 0.8.18.dev17, 0.8.18.dev18, 0.8.18.dev21, 0.8.18, 0.8.19.dev1, 0.8.19.dev2, 0.8.19.dev8, 0.8.19.dev10, 0.8.19.dev13, 0.8.19.dev15, 0.8.19.dev31, 0.8.19.dev33, 0.8.19.dev36, 0.8.19.dev37, 0.8.19.dev38, 0.8.19.dev46, 0.8.19.dev49, 0.8.19.dev52, 0.8.19.dev53, 0.8.19.dev54, 0.8.19.dev57, 0.8```

duplicity 0.8.21 was yanked ( duplicity · PyPI ). You’re in a deep pit of dependency incompatibilities.

Thanks Jason, for looking into it.
I am new to python and was not aware of dependency incompatibilities .

I’ll figure out how dependency incompatibilities can be solved.

Thanks for your assistance. Really Gratefull

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.