Deployment failing without reason or logs


My deployments keep failing even though I have put the code back to an exact copy of when the server was deploying fine. I’ve verified this by running the same code on other sites, and locally. I’ve deleted the cache and ensured I am doing a deploy from the latest code, but still it says Failed.

The log of the Failed deployment doesn’t give any insight either, I’ve left it 30mins but the latest log just shows:

Aug 15 02:44:09 PM ==> Generating container image from build. This may take a few minutes…
Aug 15 02:48:52 PM ==> Uploading build…
Aug 15 02:50:01 PM ==> Build uploaded in 33s
Aug 15 02:50:01 PM ==> Build successful :tada:
Aug 15 02:50:01 PM ==> Deploying…

Which doesn’t give any understanding why it also says “Failed”.

1 Like

I am also having a similar issue with my Nodejs - docker deployment. It builds successfully but for some reason, it says Failed.

We just addressed an issue with deploys failing for free tier services in Frankfurt. Was that the type of service you were having issues with? If so, are things working better now?

1 Like

Solved mine 18hrs ago by using an unsupported NodeJs docker image in my build which caused it to fail. Then I switched back to a supported version which worked.


I am experiencing the same issue.

Aug 17 10:56:31 AM  ==> Build successful 🎉
Aug 17 10:56:31 AM  ==> Deploying...
Aug 17 10:57:40 AM  ==> Detected Elixir 1.13.4
Aug 17 10:57:40 AM  ==> Starting service with '_build/prod/rel/streak_app/bin/streak_app start'

However. 5 minutes later I get

Deploy failed for 92c36b3

Without any reason or log which makes it really hard to track down. Region Frankfurt. Any help welcome.

1 Like

Hi, the problem is still happening for me:

Aug 17 01:47:56 PM  ==> Uploading build...
Aug 17 01:48:56 PM  ==> Build uploaded in 33s
Aug 17 01:48:57 PM  ==> Build successful 🎉
Aug 17 01:48:57 PM  ==> Deploying...

deploy id is dep-cbue4pj19n03g4rg9840 if it helps.

plan: free
region: frankfurt

nevermind, it seems to be working now

Okay, I can confirm it’s working here as well now.

Still it would be nice to be able to have some sort of logs for failed deployments after succeeded builds.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.