Deploying a public GitHub repo keeps failing

Hello, community!

I am trying to deploy a public GitHub repo to a web service. The repo isn’t mine, but I’ve run it locally and confirmed that it works. It’s a Node.js app that serves up a simple REST API.

I’ve tried deploying it a few times and it’s failed every time. Here’s a link to the most recent deploy (I’m new to Render and not sure how visible these are to Render staff + community members):

It says: Deploy failed for c7ee853: Merge pull request #48 from eliotjordan/47-send-method Fix bbox route by adding missing send method Exited with status 1

These are what the logs look like:

Jun 13 10:05:08 AM   ==> Running build command 'npm i'...
Jun 13 10:05:10 AM   audited 158 packages in 1.228s
Jun 13 10:05:10 AM  
Jun 13 10:05:10 AM   10 packages are looking for funding
Jun 13 10:05:10 AM     run `npm fund` for details
Jun 13 10:05:10 AM  
Jun 13 10:05:10 AM   found 0 vulnerabilities
Jun 13 10:05:10 AM  
Jun 13 10:05:10 AM   ==> Generating container image from build. This may take a few minutes...
Jun 13 10:07:18 AM   ==> Uploading build...
Jun 13 10:07:40 AM   ==> Build successful 🎉
Jun 13 10:07:40 AM   ==> Deploying...

I’ve tried deploying this both automatically and manually. It looks like it’s building fine, and then hanging on the deploy step (possibly timing out?) This is my first time deploying a web service and would be very appreciative of any insights + pointers on this.

Thank you all!

Hi @robert_usdr,

It looks like step 2 on the repo says to add your Postgres config: https://github.com/tobinbradley/dirt-simple-postgis-http-api#step-2-add-your-configuration. You may need to modify this for production so that the app can connect to your database. The database connection string can be stored as an environment variable on the service.

Thank you @Jade_Paoletta ! I tried deploying again it didn’t hang on the Deploying... step :clap: (maybe that was just a one-off?)

After that I got a different error message that involved the config file you pointed me to, so you were spot on. Appreciate your insights and help on this!

Robert