Custom domain failing


I moved the dns host from digital ocean who was hosting a ghost site to hover, which is my domain registrar.

At hover I added a cname record:

When I do lookup, I see that the path leads to Fastly, so that is good.

Hover shows up as the DNS provider, so that is good.

Firefox reports a certificate mismatch so I have to go past the “hazard tape”. When I do that reports Not Found.

So, it looks like propagation has sort of occurred but is broken.

And new certificates have not been created to match the custom domain.

How to fix? Or, how long should it take to straighted itself out.

So here is the problem. Hover just doesn’t handle forwards sensibly. Who have you had better experience with. (WITHOUT https://) resolves to hover says there is NO WAY to forward from because there is no cert associated with I suppose that is true. But, I didn’t have that problem with Digital Ocean hosting a ghost site and the DNS records with Hover as the registrar.

Hover cannot support cname @ to

The other problem with the hover approach (a records to themselves, with a forward to is that users have to delete https:// when they type in Every modern browser tries to enforce https for secure browsing so users have to manually delete the https://–which they never do for anything else. So, this is a non-starter.

the second problem is that as users click around the site, the urls they see are: and not Users should never see that is the whole point of custom domains.

So, tell me that this works correctly with cloudflare or cheapnames. I am happy to kiss hover goodby. they may be well priced and basically ethical, but apparently technically limited. The support person actually recommended cloudflare. But, what she meant was keep the domain name at Hover, so they got the renew fee for doing nothing, and host the DNS records at cloudflare (which was basically what I was doing with Digital Ocean and Hawkhost (for some older wordpress blogs)).

I want to move the whole shebang to another provider. There is no reason to keep paying hover for being a technically limited registrar.

How can I verify if this will work correctly at cloudflare or namecheap or anyone else.

Sorry this is long. I thought this would be trivial but nothing is trivial.

I have chosen to disregard Hover’s instructions and followed Render’s.

I now have: A @

I also had not filled in the field in the custom domains area. I have done so now.

It seems to have not propagated yet.

it is possible that I will have to go back to Hover’s recommentation of A records to hover with a forward.

it is possible that the problem with the URLs within the site was caused by not putting in the name in Render’s field (which must control how url’s appear for the <> site name.

Too many moving parts and too slow to test what is happening.

Switched to cloudflare. Followed your instructions. Easy.

Resolves to my site. Resolves to the same. (although sort of optional)

The results look a little different than your doc. the CNAME record for resolves to www when saved. CNAME flattening is turned on automatically. Assume this is all right.

Users can type in or or and it resolves correctly to This is the most important improvement.

However, the intermediate links come up as This is not the end of the world though when someone might copy/paste a link or save it to readlater or pinboard, etc–the link is not to the root domain. At some point I need to get rid of test-view (this is a holdover from getting things setup). The saved links will naturally break.

Is there a way to solve this? Sort of seems like there should be.

Solved. The page urls issue had nothing to do with the dns settings or https, etc.

I just changed the base URL in hugo to the domain. (This would have worked with hover, although ssl would still have been a problem.