Clear Build Cache

Is there any way to clear the build cache on every deploy? For some reason, every time I push any updates to my web service, the build fails. If I go in and manually build and clear the build cache, it works.

Is there a way to specify in my Render.YAML that the build cache should be cleared on each deploy?

Hi patagoniapy,

Currently, there isn’t a way to specify that in your render.yaml however you can trigger a deploy and clear the cache using our API. If you don’t mind sharing which service is having trouble I can take a closer look. You shouldn’t necessarily need to clear the build cache to have a successful deploy.

I am experiencing the same issue. Can we add a UI setting to disable cache?

In my case, there is a bug in Render’s deployment system that was being confused by my render.yaml specifying the free plan after I had manually upgraded to starter via the UI. Maybe check that and see if it fixes it for you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.