All deployments from Gitlab fail

It looks like either you or Gitlab is having issues currently and all deployments fail across all my services.

I get this message in log:

It looks like we don't have access to your repo, but we'll try to clone it anyway.

After multiple retries, it stops.

Could someone from your team verify whether this is an issue on your end? I will also reach out to Gitlab support in case there some connectivity issues from their end.

UPDATE: I really looks like something on your end as other services I use to talk to Gitlab to push/deploy code work just fine.

UDATE 2: When I click “Manual Deploy” button, I am getting popup with “Error: Internal Server Error” message.

4 Likes

I’m having the same issue as well.

3 Likes

Same issue here

Update: I tried to setup a new web service connected to a Gitlab repo, and Render had no issue querying the names of all my gitlab projects for that. (I did not follow through with setting the service up, I expect it to fail as well)

2 Likes

I have the same issues. All gitlab repos are not reachable. The CD-pipeline shows the following error:

     fatal: could not read Username for 'https://gitlab.com': terminal prompts disabled

That means, the render.com-system can not clone the repository from gitlab :frowning:

Confirming this works as temp solution. Looks like some issues with authentication on Render’s side.

So, simply:

  1. Go to Gitlab and set up any new, dummy repo.
  2. In Render dashboard, click “New” and select Gitlab as a source and pick that new dummy repo from the list of Gitlab repos. Don’t proceed with the actual setup, just click the oauth link if you see any.

This should “refresh” the connection accross all repos in that Gitlab account and you should be able to deploy normally :slight_smile:

However, I still feel Render team should look into it to provide less “hacky” solution. Perhaps there is another, more serious underlying issue.

3 Likes

Great! This works … I refreshed the gitlab-connection only.

UPDATE 3 hours later: It doesn’t work permanently. The error returned and I had to repeat the fix. That’s a bad behavior :-1:

1 Like

From the incident from the status page:

A fix for expiring GitLab tokens is being worked on. You may find GitLab deploys start to fail around 2 hours after connecting your Render account to Gitlab.
Until the fix is in place you can workaround the failures by disconnecting and reconnecting GitLab to your Render account:

I’d put the rest but new users can’t post more than two links.

Just to close this topic out - This incident was fully resolved and a fix is in place now so that workarounds don’t need to be used.

1 Like