YAML Preview pull requests, environment variables and not activating

Hi,
I have:

previewsEnabled: true
previewsExpireAfterDays: 2
services:
  - type: web

at the top of my render.yaml file.
I can see this in the YAML overview page:
image

However in github when I create a PR I dont get a URL or anything suggested the PR environment/preview from YAML has started

So it seems the requirement for PR previews is picked up from the YAML however no PR preview seems to be being deployed.
I then activated PRs manually in the UI (outside of YAML config) and that created a PR preview, however that didn’t respect the a) price plan I wanted and specified in the YAML

    plan: starter plus
    previewPlan: starter

and nor did it respect the environment variables for the PR preview:

      - key: IS_PRODUCTION
        value: true
        previewValue: false
  • in this case the value in the PR is also tru and the plan is starter plus.

So, how do I get the PR previews, that are managed from yaml to respect these.

Based on this, how can I now turn off manual PR previews in the dashboard, to allow this to PR environemnts, defined in YAML to take over

This was resolved in private messaging.

The issue was that the PR did not include a render.yaml file. As well, the concept that helped us resolve this issue was the difference between the Service PR Previews and the YAML Preview Environments.