Unable to sync git submodule when deploying (private repos)

May 24 02:44:52 PM  ==> Cloning from https://github.com/dechimp/nc-docker...
May 24 02:44:53 PM  ==> Syncing Git submodules
May 24 02:47:03 PM  fatal: unable to connect to github.com:
May 24 02:47:03 PM  github.com[0: 192.XX.XXX.XXX]: errno=Connection timed out
May 24 02:47:03 PM  
May 24 02:47:03 PM  fatal: clone of 'git://github.com/dechimp/nc-core.git' into submodule path '/opt/render/project/src/core' failed
May 24 02:47:03 PM  Failed to clone 'core'. Retry scheduled

The project is a private repo with two private submodule repos. All repos belong to me, and render has permission to access my repos. I also tried reconnecting my Git account in Render but am getting the same error. Thanks.

Hi Ricky,

We have recently started seeing issues when git repos are referenced with “git://” protocol, likely related to this change from Github. Could you try changing the submodule reference you use to this format “git@github.com:dechimp/nc-core.git” instead, this should be in the .gitmodules file.

Please let me know if that works.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.