Reversed Order of Web Service Logs

Logs for web services used to be displayed in chronological order, which was great because multi-line logs would be readable in the expected order (the order in which they were called, from top to bottom).

A recent update has reversed this order, which not only makes them harder to read, but also breaks the output formatting for multi-line logs. Take, for example, a multi-line JSON object:

{
  "foo": "example",
  "bar": "hello, world"
}

This will now appear in the logs as:

}
  "bar": "hello, world"
  "foo": "example",
{

When you have multiple objects logged back-to-back, this gets especially confusing to read. I love the new log filtering options, but please undo the change that made logs appear in reverse chronological order!

Hey Sebastian,

We’ve taken note of your feedback and understand your perspective. To be honest, you could make a case for both approaches—it really depends on what you’re accustomed to and what you perceive as a natural flow. Indeed, the top-down flow does have its limitations, especially when displaying objects, as you mentioned. They might appear somewhat ‘reversed’, even though objects theoretically don’t have an order. I get what you’re saying.

We’re exploring several options to enhance the user experience, so keep an eye on your dashboard for any new features and improvements that will be coming soon.

Jérémy.
Render Support, UTC+3

Hi Jérémy, thank you for your response. It looks like this has been fixed with a new toggle allowing users to sort using either chronological or reverse-chronological order.

Screenshot 2023-11-28 at 22.47.54

To clarify the earlier point on reversed objects–it’s not necessarily an issue that the properties are displayed in reverse order (although for an array that might be an issue)–rather, the problem is the broken syntax from the flipped braces and lack of trailing commas, which becomes especially apparent when you have more than one multi-line object logged back-to-back or if you try copying and pasting a logged object into your editor.

In any case, very glad to see this fixed! Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.