PR previews not working

I have the integration between Github and Render properly set up, and I use the “auto-deploy” feature with no hassle at all. Immediately after pushing/merging to “develop”, deploy starts on my web service.

But for some reason the “PR preview” feature is not working for me. Nothing appears under the “PRs” tab and no comment/deploy is added to the open PR on Github, despite having this feature enabled under the “Settings” tab.

I thought render.yaml was only required for using “Preview Environments”, not for “PR Preview”. Am I wrong? Am I missing something?

Thanks!

Update: still not working for my own PRs, but worked for Dependabot.

Hey Marcos,

Are you making pull requests from a forked repo? PR previews from forks are not currently supported.

Nope, it’s an original repo inside our organization. Dependabot PRs properly created previews, but actual PRs from me didn’t.

I appreciate your follow-up, thanks!

Got it. Could you share a repo name, branch name, and timestamp of a PR that you opened that didn’t trigger a preview? Feel free to DM me if you’d prefer.

Thanks, just sent you a DM.

For anyone facing this issue in the future:

As of today, it looks like Render doesn’t quite like if branch names contain special characters like “#”. Removing special characters solved the issue for me.

2 Likes