I'm using node version 20 but when i go for deploy i fetched

error mongoose@8.0.0: The engine “node” is incompatible with this module. Expected version “>=16.20.1”. Got “14.17.0”
Nov 3 06:36:36 PM error Found incompatible module.
Nov 3 06:36:36 PM info Visit yarn install | Yarn for documentation about this command.
Nov 3 06:36:36 PM ==> Build failed :disappointed:

1 Like


You need to upgrade the Node version your service uses to a version that suits your application. https://render.com/docs/node-version

Render Support, UTC+3

i updated my node version but still getting the same error

1 Like

Hey Sabbir the issue is that, Render environment is using a different version of Nodejs which is not compatible with your version of Mongose.
so to easily fix this, go to the environment tab, add a new environment NODE_VERSION and give it a value of your NodeJs version and click save.

see this picture below for example :point_down: :point_down:

in the above picture i set the node JS environment to 16. with this now the Render environment will use my specified environment to run your Applicaion.

then when you go to your logs you will see something like this
Screenshot from 2023-11-08 11-11-27

This should solv your problem, Let me know if you have any other issue,


Where did you update your node version. on your render dashboard or on your local machine ( Node Application )

Hey Anurag,

Are you still getting an error or the same error?

Render Support, UTC+3

1 Like

Anurag please confirm this.

If you are still getting same error

I have done this but i am still getting the same error.

I am having same issue.

Please how can i fix it?

Can you please confirm what you’ve changed since you first posted here and what error you’re seeing?

Render Support, UTC+3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.