Using Node 18 but its telling me my node version is 14.7

This is my first time using render and I am getting this error
error bson@5.1.0: The engine “node” is incompatible with this module. Expected version “>=14.20.1”. Got “14.17.0”

my node version is 18.13.0 can anyone advise on why I am getting stuck on manual deploy<

i still get the same issue. really do not know what could be the cause.


Are you still encountering the error? Make sure to specify the node version via the “NODE_VERSION” environment variable:

Jérémy, Render Support

1 Like

Add an environment variable called NODE_VERSION to your app and assign to 14.20.1

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.