Deploy failed due to "different" node versions

Im trying to deploy my webpage for a uni project but Im having several issues. The main one is that I got a deploy failed message and in the console appears the following message:

error mongoose@8.0.1: The engine “node” is incompatible with this module. Expected version “>=16.20.1”. Got “14.17.0”

But I checked my package-lock.json and I indeed have the node version that is required for mongoose


I’ve even done ctrl + f the number of the version that “it found” but couldn’t even find it so idk what’s wrong. Help would be very much appreciated. Thank you for your time.

Hi there,

These are the requirements for Mongoose, not what you are setting in your services package.json. Please see here how you can set the NodeJS version for your service:


Render Support, UTC+10 :australia:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.