GitHub ID belongs to an existing Render user

When I connect my GitHub ID I get:

The GitHub ID xmeltrut belongs to an existing Render user. Please log in to GitHub with a different ID.

I have checked to see if I have another Render account but I don’t. And I’ve tried revoking Render’s access on Github and reconnecting there cannot be another account connected to my GitHub ID.

Anything else I can try?

Hey @xmeltrut, are you still running into this issue? I checked and I’m not seeing any existing Render accounts linked to that Github username.

Thanks @Jade_Paoletta, yes, still happening at the moment.

Hi @xmeltrut, can you see if you are able to get it working via the following steps:

  1. Sign in to the GitHub account that you’d like to use with Render.
  2. Visit each of these URLs and delete or revoke any “Render” apps that you see:
  3. Sign in to your Render account.
  4. Visit your account settings page. You can find this by pressing your name in the top-right corner, and then choosing “Account Settings” from the menu.
  5. Press the “Connect GitHub” button
  6. Follow the prompts to authorize the Render app.

Let me know if that helps, or if you’re still having issues.

Perfect, thanks, it’s working now!

I tried that previously and had no luck. But this time I tried signing out of Render and then back in.

1 Like