DNS Update for Custom Domain but site cannot be reached

I have set up a site on render - sicjournal.onrender.com - which works fine, and I am trying to set up my custom domain sicjournal.org that I have with Cosmotown.

I have added an A entry (having deleted all existing ones) as well as a CName entry as advised.

I have deleted AAAA entries and no other entries exist in Cosmotown’s DNS Management settings page. I have reset the nameservers to the default Cosmotown nameservers (which are responsive and can be pinged and have propagated - can be seen in whois). However, I get server failure when I try to go to my custom domain. I checked OpenDNS and tried refreshing but I still get SERVERFAIL everywhere. The last update I did to the records was yesterday morning. Is it just a matter of time for it to work or could there be a problem and how can I diagnose it?

I haven’t seen ANAME or ALIAS settings in Cosmotown’s platform, but there is an URL forwarding service. Would that work as an alternative?

Thank you!

It looks like it was a matter of time because it works now!