DNS not found, site can’t be reached

Added a custom domain, updated CNAME DNS records, certificate has been verified, however I get a DNS record not found for URL custom domain. The render URL works with no problem but does not redirect to the custom domain? Any help? Thanks

Hi Bob,

Thanks for reaching out.

Could you share the domain or service ID so that I can take a look?

Thanks.

Alan

Thanks for the quick reply. The render URL is a simple “hello world” html file at https://roberthunt.onrender.com/. Works ok, but it won’t publish on the custom domain at roberthunt.com

Hi Bob,

Thanks for the added detail.

When adding a www or root/apex custom domain to Render, the other is added as a redirect, this is documented in the bullet points in this part of the custom domain docs: https://render.com/docs/custom-domains#adding-a-custom-domain

It appears you’ve added the roberthunt.com custom domain to the service, so www.roberthunt.com was automatically added to redirect to roberthunt.com. However, it appears you’ve only added DNS record (a CNAME) to www.roberthunt.com. You’ll also need to a DNS A Record to roberthunt.com pointing to 216.24.57.1.

Hope that helps

Alan

Thanks Alan, I tried that before and for some reason network solutions wouldn’t allow me to add the A record. I tried it again and was able to update the A record and verify the certificate. However, the site still won’t publish. Do I need to wait for this to propagate?

I’m seeing patchy results on the roberthunt.com DNS records: https://www.whatsmydns.net/#A/roberthunt.com

It may be a propagation waiting game, if the records are already set in your DNS provider.

Alan

ok, I’ll give it some time and update here in a few hours. Thanks

Appears to be working now. Thank you for your help.

Thanks for the update and glad to hear it’s working.

Thanks for using Render!

Alan