Disk snapshot restore doesn't appear to work

Hello,

I had issues with a deploy over the weekend. I tried to do a disk snapshot restore. It (Render) indicated it was restoring, and then redeploying. Due to shell access only being provided after a successful deeply, there is no way for me to see what is restored until after the deploy. And, after the deeply we did not have the data that should have been on the disk.

It appears that rather than restoring, it essentially wiped the disk, those losing the current data and not getting the restore snapshot!

I tried numerous days of the restore and various combinations of actions to no avail. I had to go back to a month-old backup and accept data loss to get the application running again.

So it appears that either:
a. The snapshot restore feature may not work; or
b. The deploy process somehow stomps over the restored snapshot (doesn’t seem likely because a normal deeply doesn’t overwrite the disk).

Any comments or suggestions? I still wouldn’t mind recovering my data either!

Hi @cjreimer,

My apologies that this happened. I just tested the snapshot restore process on one of my own services and I was able to successfully restore the disk to a previous state. Can you let me know which service was affected so I can take a look? Also, do I have your permission to try restoring the disk again to see if I can reproduce the issue?

Tyler,

I just messaged you directly.