Deploy is successful but all connections return 404, logs show nothing

I’ve deployed a web service but all connections to it return an instant 404 page.

I’ve tried connecting to several different endpoints and they all return a 404 page, but the server logs dont show any incoming request, as if the requests never even reached the server.

Even more puzzling, sometimes the request will randomly go through if I keep trying to reload the page, and only them will the server logs show anything.

Edit: And now, after an afternoon of trying, just as I posted this, relaunching the web service with region set to US West instead of East seems to have fixed it.

Experienced similar behavior as mentioned in this post.

Deploying to Oregon also worked correctly - consistently serves the web page, but Ohio deployment is still mostly giving 404.

I experienced this as well, with free services in the ohio region. I reported it to Render’s support yesterday, but have not yet received a response. However, I decided to try upgrading from free to paid services, and the 404 problem is resolved. There does seem to be a problem with at least some free services in ohio - would be nice to have this acknowledged and reflected in Render’s status.

Hi,

We’re very sorry for the delay in response here. We can confirm that there were issues resulting in intermittent 404 responses on Ohio free tier services. We’ve rolled out a fix for this, so Ohio free tier services should be seeing more consistent responses now. We’ve also updated the status page to reflect the issue: https://status.render.com/incidents/jj48hy2852fp

Thank you for bringing this to our attention, and again, we’re very sorry for the disruption here.

@Lcrs123 - I’ve checked your service and suspect you may be running into a separate issue. Could you email support@render.com and we’ll be happy to further assist you?

1 Like