Deploy gets stuck and never finishes

I tried to deploy my app but it gets stuck in the deployment step. It doesn’t seem to thrown an error but never ends.
Any idea why this could be happening?
I have deployed this application many times before always successfully.

The last lines of the log:

Apr 20 07:09:02 AM ==> Uploading build…
Apr 20 07:09:35 AM ==> Build successful :tada:
Apr 20 07:09:35 AM ==> Deploying…

1 Like

Hi,
I’m facing the same issue with my api today.
Yesterday, everything was okay when deploying. Today, it seems to be stuck at “Deploying…” and doesn’t throw any error.

Thanks for your further help on this.

Have a nice day,

This has happened to us several times over the last few weeks - also facing this today.

Same problem here, can’t get my service to run now for 3 hours, always timing out.

I tried to redeploy manually today and this time it worked fine.
I didn’t change anything, the same commit was failing before and now it worked.

Hey folks, we identified the issue causing Frankfurt region deploys to timeout out intermittently and believe it has now been resolved. Please let us know if you continue to encounter issues, and apologies for the inconvenience caused here.

1 Like

I initially ran into this issue a handful of times about 2 or 3 weeks ago. Since then everything worked fine, until today. I ran into two timeouts again this morning. Only a cache refresh + manual build solved it.

Service ID srv-c1m2cpjs1gh7e05g6qhg
Deploy IDs dep-c237jh7cq1lidlj26g00 and dep-c237n5fcq1lidlj26k10

I’d appreciate if you could look into it.

We’re investigating @simon. Thanks for the detailed report.

1 Like

Hi @simon, we’ve put some mitigations in place for this issue (see Render Status - Deploys timing out for services in Frankfurt region). Please let us know if you continue to see issues.

Will do. This issue had been marked as resolved a few days ago and now happened again now. Do you expect these mitigations to be a sustainable fix or is there a broader / longer term issue?

Good question. With these mitigations, I expect that the issue will recur less frequently. Meanwhile, we will prioritize finding a more sustainable fix.

@david we’re running into deployment issues again. This time the deploys show no logging at all and don’t seem to time out. See dep-c29raam31hsd4fdecjtg or dep-c29r24u31hscgoaesjfg.

This is blocking app deployments right now - I’d appreciate if someone can look into it asap.

1 Like

Hi, I’ve joined render yesterday, and had no problem to deploy anything. Today, I can’t get my web service to deploy, with the logs being empty (I had no problme deploying static websites). I’d be glad if you had any solution for me :slight_smile:

We’re running into deployment issues over here as well, we’d appreciate looking into it ASAP.

Hi, I`m running also into deployment issues, logs also empty.

Same here, last successful build for me was May 5th, 17:56 UTC.

Same here, multiple node services in the Frankfurt region

Same for me today, my nodejs app stuck

Same again for us - for the last few hours. (Frankfurt)

I am getting the same thing. Logs empty whenever trying to do a deployment. Frankfurt Region