Deploy failed due to docusaurus node engine

I see this error when trying to deploy my docusaurus site

error @docusaurus/core@2.2.0: The engine "node" is incompatible with this module. Expected version ">=16.14". Got "14.21.2"

I updated the node engine in my env settings to “14.21.2”. Render detects the Node version, but still throws the above error.

I’ve tried updating the yarn build command to use the -ignore-engines flag, but that did nothing.

Any suggestions? Thanks

Render defaults to node 14. Docosaurus requires 16.14 - so just tell render to use version 16 and in your yarn/package file just set

engines: {
  node: >=16.14",
  npm: "8.x"
}

to use node 16.14 and higher

You can read more about in the docs: Specifying a Node Version | Render

1 Like