Can't turn off auto-deploy for Docker service

My setup:

  • render.yaml blueprint with a couple of services
  • one service is a docker pserve with an external repo configured
  • autoDeploy for that service is false
  • The web UI also shows auto-deploy as being turned off
  • srv-cf15ljh4reb5o40v9oa0

However, whenever I push any change to the repo containing the render.yaml, it automatically re-deploys the docker pserve.

The render.yaml doesn’t change nor does the external repo I configured for this service. Auto-deploy is disabled as well. So why does it still auto-deploy on every commit?

Marc,
I’ll follow up directly,

Regards,

John B