Web services show "no healthy upstream"

I created two web services yesterday, one was copied from Render’s Express-Hello-World. The two web services were deployed successfully and worked well yesterday. But now, they all show “no healthy upstream” with a status of 503. I am not sure if this problem caused by Render’s servers, or my codes/settings?


And just now, the web services show 502 error.

From https://status.render.com/, it says

" [Degraded Free Services in Oregon]
Identified - We identified issues with free tier services in Oregon at 4:23 PT. Users may have experienced problems with their free tier services, including incorrect 404s. We are in the process of rolling out the fix.
Oct 18, 2022 - 02:00 UTC"

I am relived that it’s not my codes/settings problem, but I am also worried about the stability of Render’s services.

1 Like

I also started using render service and had same issue.
Glad to know it’s not my code/settings problem!
Thanks for information.

I’m experiencing the same issue with my site.

hello everybody
the same
upstream connect error or disconnect/reset before headers. reset reason: connection failure

Hi there,

Thanks for reaching out.

Is the service in question a free plans in Oregon or Frankfurt?

If so, we have open incidents for those, updates will be posted on the status site: https://status.render.com/

Apologies for the inconvenience.



It happened to me a couple of times since I switched from Heroku free tier to Render free tier. Now, I am worried about the stability of Render’s services?

Getting error: “no healthy upstream” and
“upstream connect error or disconnect/reset before headers. reset reason: connection failure”
on site that worked until today: https://freelancerforms.onrender.com/

Is there something I should do to make it work?

Hi All,

Just following up, have you been able to deploy/reach your services?

If not, please feel free to open a ticket at support@render.com with specific details so we can investigate further.

Kind regards


The web services are back last night. Thanks to Redenr’s team for the effort.

This problem may be back. I can successfully deploy a web service to the Oregon environment, but when I try to access it, I get “no healthy upstream”.

This now seems to be resolved. Is there a delay between notice of a successful build and availability of the site?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.