Upgrading plan makes builds time out


I’m switching our hosting provider from Heroku to Render, but I’ve been having some difficulties getting started.
I started out running a web service on the free tier which worked fine, but when trying to change the plan from a Free one to f.x. Standard, the build just times out.

I found a few posts already where the solution was to bind to, but that does not seem to do the trick for me. I’m using express, and have tried starting the application with both app.listen(port, callback) and app.listen(port, '', callback).
I can see in the server log that the server is started successfully so the issue seems to be with communication from render to the server (a health check path is defined).

Excited to resolve this and finish our move to Render! :smile:

Hi Hannes,
I’ve escalated your email to our support team to our engineering team to investigate,

John B

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.