Deploy of nodejs Web Service successful, server started ... but how can I reach it?

I selected Render Web Service in order to deploy and run a node/express application which is already running from the same soures on Heroku.

I’ve been looking for Heroku alternatives lately, so I “stumbled upon” render.

When I created the Web Service, the deployment finishes correctly and I can even see the server startup message (web server on port 10000 and Atlas connection)

But, I cannot open the site with the URL given on the Dashboard … so how can I reach the running web service?

Hi there,

I took a quick look at your service and it is on the Free Plan which has slightly different behavior than paid web services. Sometimes initial requests to Free Plan services can take up to 30 seconds while they wait for the service to spin up. I was able to access yours once it was able to accept requests.

Yes, thank you

Initially, I tried several times and never received feedback. After ~20 minutes I tried to access it again, and after a short spinup time it responded smoothly.

I see the same issue as devnull69. The service spins up fine, listens on port 10000. But it takes a lot more than 30 seconds before it becomes reachable. More like 5-10 minutes. Weird behavior.

Ok, so it is not just me. So can I do anything about this delay? I tried it several times and the first response time after spinup is always > 5 minutes :frowning:

Hi all,

Apologies for the delayed response here! If your application is experiencing issues starting up outside of the Free Plan limitations please reach out to with details of your service (link to the dashboard page for the service, id, name) and a detailed description of the issue so we can take a closer look.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.