Timeout when connecting to database (singapore) with Laravel

Has anyone tried connecting to the postgres db with Laravel?

I keep getting

SQLSTATE[08006] [7] connection to server at “singapore-postgres.render.com” (, port 5432 failed: timeout expired

When I try to connect to the render database from a local Laravel setup. It works fine in prod (it’s using the internal db connection via the setup laravel render guide).

I put the external connection url, hostname, port, username and password so it should work. Is there a problem for external connections? The db allows in the allow list as well.

Hi there,

Have you tried using the external PSQL command from your local computer just to rule out any connectivity issues? If that works, then it suggests it’s a Lavarel config issue for the database

John B

Will try that now and see what’s up.


I turned off my VPN and could connect with the PSQL command. Was there some form of blocking for VPNs? (Protonmail one) for connecting to the postgres db?