Strapi V4 on Render

Anyone get this working? I set up account. I used the render.yaml and made some changes (could be problem), copied config folders from repo, created blueprint instance but fails. I had buildCommand: npm build instead of yarn build as I use npm locally. Tried both and both failed but when I tried npm build the error log asked if I meant npm run build? Should it be npm run build or npm build?

When the config folders are copied from the git repo are any changes required to the files in those folders?
I read that disks are not supported for free plans so maybe that shouldnt be in render.yaml file?

This is my render.yaml file, below.

Any suggestions welcome. Thanks!


  • type: web
    name: strapi
    env: node
    plan: free
    buildCommand: npm install && npm build
    startCommand: rsync -a public/ /data/public/ && npm start
    healthCheckPath: /_health
    autoDeploy: false
    name: flip_data
    mountPath: /data
    sizeGB: 1
    • key: NODE_VERSION
      value: ~16.13.0
    • key: NODE_ENV
      value: production
      value: /data/strapi.db
    • key: JWT_SECRET
      generateValue: true
      generateValue: true
    • key: APP_KEYS
      generateValue: true

Hi there,

Thanks for reaching out.

As you mentioned, the Blueprint is defining a free plan defined with a disk, and you’re right, disks aren’t available on free plans. This should usually be highlighted by a failed sync on a Blueprint.

Hope that helps


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.