Keep getting same error when trying to deploy a strapi app

Hi all,

I keep getting this error when trying to deploy a strapi application. I am using the blueprint with a render.yaml file

Sep 21 10:53:10 AM  rsync: mkdir "/data/public" failed: No such file or directory (2)
Sep 21 10:53:10 AM  rsync error: error in file IO (code 11) at main.c(682) [Receiver=3.1.3]

Here is my render.yaml file

services:
  - type: web
    name: strapi
    env: node
    plan: free
    buildCommand: yarn install && yarn build
    startCommand: rsync -a public/ /data/public/ && yarn start
    healthCheckPath: /_health
    disk:
      name: strapi-data
      mountPath: /data
      sizeGB: 1
    envVars:
      - key: NODE_VERSION
        value: ~16.13.0
      - key: NODE_ENV
        value: production
      - key: DATABASE_FILENAME
        value: /data/strapi.db
      - key: JWT_SECRET
        generateValue: true
      - key: ADMIN_JWT_SECRET
        generateValue: true
      - key: APP_KEYS
        generateValue: true
      - key: API_TOKEN_SALT
        generateValue: true

when I had

plan: standard

it deployed correctly.

I removed the

rsync -a public/ /data/public/ && 

from the startCommand and I still get the same error.

Hi Ryan,

Thanks for reaching out.

Disks are not supported on Free plans. You would need to keep it on a paid plan in the blueprint to be able to retain the disk.

Hope that helps

Alan