Service not ready

Same exact thing happens: manual deploy works for few mins and again back to the throwing same error.

Glad I am not the only one. Spent a few hours on this. Thought it was me

its the same for me, after re-deploy, that work just few minute and same error message like others.
i think i will just migrate to Vercel faster XD

i got the same issue! , i’m re-deloying the project! i hope that works!

Nó lại die rồi

my service is up and running, checkout yours!

Same error, even I restart/redeploy my site manually, it will be shown in a few hours.

I am facing this issue. It persists even after redoplying my app. I am on a free tier. Render team please look into this seriously. My app is automatically failing after 5 minutes and showing no error logs sometimes. I tried redoplying but it doen’t work.

Facing the same issues!!! re-deploy for many times and still not working, my app runs all good locally tho. Who can help me?

This service is not ready to serve traffic. If you are the site owner, please check that your service is passing health checks.

Can anyone from help here?
Getting same error for all of my apps.

Chán vl, hàng free nên chịu thôi

1 Like

Same problem at yesterday.

My web service has also been unreachable since yesterday. It gave me this message as well: “This service is not ready to serve traffic. If you are the site owner, please check that your service is passing health checks.”

What are health checks? I am running a Python app as a web service but the docs do not explain what health checks are.

It is interesting that a lot of other users are affected by the same problem. On the other hand, I observed that a different Python app, which I am running in the same way as a web service, is still reachable. So there is something about this particular app that is causing the problem. What could it be? The problematic app is different in that it runs slightly more time-consuming computations. It therefore has been running relatively slowly to begin with. Could this be a problem? I guess the docs need more clarification on how to deal with health checks.

I should add that I could resolve this issue for now by simply re-deploying the app (as others have described above). But I am expecting this issue to resurface in the near future. We’ll see… :tea:


1 Like

The time has come. I’m finally forced to learn docker.


Hi! My service went down again! Today in the morning was up and running! Hope that issue can be solve!

Yeah same, I have now implimented a monitor which is monitoring all my services that triggered a deploy using the render deploy hook (can be found in project settings) whenever the service doesn’t show up a 200 response.

hi! commmunity! i have redeployed the app again, and … it’s works!

works how many time? ^^

It’s still working! :slight_smile:

Still i have this issue. What can we do now?