REST API Not Exporting CSV To User

Hi there!

I’m rather new to this! I just uploaded my first REST API using Render. The user sends a POST request of their path to which the csv will download too. I can confirm that my API is reading in the path since it prints in the log however it will not actually show up in my folder. It worked when I ran the API on localhost, so is there anything I can do to make sure the csv gets downloaded fully onto the user’s computer?


I do realize the forward slashes clash with the last backslash… that was an attempt to flip them around and see if it would change the outcome.

Hey,

It seems like you’re using a Windows-style path, but our servers run on Linux, so the path format you’re using won’t work. In Linux, we don’t use backward slashes or drive letters like ‘C:’ as you would in Windows. It looks like there’s a bit of confusion about how the filesystem works on Linux. I’d recommend familiarizing yourself with the Linux filesystem to help resolve this issue.

https://www.linuxjournal.com/content/linux-vs-windows

Jérémy.
Render Support, UTC+3

1 Like