Password authentication failure while connecting to Render PostgreSQL service


I’m currently running into an issue while trying to build and deploy my web service.

When I run my build, I am able to install all necessary dependencies, however, once I try to connect to the PostgreSQL instance I created, I receive the following error:

connection to server at “server name” (, port 5432 failed: FATAL: password authentication failed for user “user name”.

I checked my environment variables, and the DATABASE_URL is correct and matches the internal URL for my PostgreSQL instance. The password is also correct.

I am able to successfully log in to the database on my local machine using the PostgreSQL command provided by Render with the same credentials.

I have tried deleting and creating new database instances with no luck.

Any insights or guidance is appreciated!

Hi Nick,

Could you past your Database URL here? Be sure to hide the password section of the URL.



Sure, it’s:


Hi Nick,

Thanks for that. It looks good to me.

Could you double-check that the password you have entered in your service matches the value from the databases settings page?



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.