Nodejs Backend Deploy error

I created my backend using Nodejs. When I try to deploy my Backend I get this error

error mongoose@7.2.2: The engine "node" is incompatible with this module. Expected version ">=14.20.1". Got "14.17.0"

Here’s the repo I’m trying to deploy

1 Like

Hello again :slightly_smiling_face:

If you check the deployment output for the service, one of the first few lines of the output will show the version of Node your service is using and then a link to the relevant documentation on how to change it,


John B
Render Support, UTC+1 :uk:

Hi there. Thank you for your message. Yeah it says it using 14.17.0

How can I update or change that?

Hey, hi! I was running into this issue as well and fixed it. What you have to do is go to your package.json file and add :

  "engines": {
    "node": ">=14.20.1"

This worked for me. Do let me know if it worked for you as well! Cheers!
PS: Don’t forget to commit and push changes to your package.json file in case you’re using Github.


Thanks, man. I find it :slight_smile:
But Now got another error. While testing server loads more than 10s

My route:

This is the error I got.

"success": false,
"message": "Operation `courses.find()` buffering timed out after 10000ms"

If you have any suggestions please tell me

Nevermind. It’s an error from Mongodb :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.