==> No open HTTP ports detected

Hello, I’m trying to deploy my rust project and i get " ==> No open HTTP ports detected" error. How can i solve this?

Hi Balogun,

Could you try explicitly setting a PORT environment variable to bypass the automatic detection?

You might also check that you’re binding to and not localhost or

See https://render.com/docs/web-services#host-and-port-configuration for more information.

Give that a try and let me know if it helps.



1 Like

I’m getting the same massage “No open HTTP ports detected”.
Is it a change that happened recently?

I didn’t change my config, and now can’t deploy because of this message.
I try to set manually PORT 10000 in env variables, but it also didn’t work, this time I had: Timed out after waiting for internal health check to return a successful response code at: www.yyy:10000/api/healthz

1 Like

I’m still not able to deploy after setting the port to 10000 in the env, I got a timeout and the deploy failed before the port could return a OK

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.