New Environment Variables Not Being Created


I’m experimenting with Render’s free tier to see if I can move some services over to the paid tier. I’ve noticed that once I create a web service, if I later create a new environment variable in render.yaml with sync: false, it doesn’t automatically get picked up or prompt me to enter it the next time the sync happens.

Even when I click manually sync, the environment variable doesn’t come over. I could of course add the environment variable manually in the dashboard, but want to make sure I’m not missing something.

Hey there, yeah, this is a failing of sync:false - you’d only ever see a prompt for it when you first create a new blueprint instance, you’re never prompted again for it. Right now, entering it manually via the dashboard is your best option. We’re working on a whole load of blueprint improvements to address some of it’s short comings.

John B

Great! Makes sense. I think the Docs could be clearer on this, but if you’re overhauling the Blueprint system anyway, I’m sure this is something you’ll address. Thanks for the response.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.