NestJS build successful but deploy stuck on error

Hello there,

I recently deployed a nestJS application to the platform but it seems to be stuck in the a database connection loop with the error.

Dec 4 04:40:24 AM  [Nest] 60  - 12/04/2023, 12:40:24 PM   ERROR [ExceptionHandler] 
Dec 4 04:40:24 AM  AggregateError
Dec 4 04:40:24 AM      at internalConnectMultiple (node:net:1114:18)
Dec 4 04:40:24 AM      at afterConnectMultiple (node:net:1667:5)

I have done the following;

  1. Created a postgres database
  2. Added the database config to the environment variable.
  3. Specifically used the external connection variables.

Kindly help


It’s tough to help you here at this point, have you tried to start this app without any database connections? Are you seeing any other logs? Is the app starting correctly up to this point? Have you tried using the internal connection string? Have you tried to connect to this database using the external connection string via your local machine?

Render Support, UTC+3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.