My app URL is loading infinitely

I am using the Render free tier but I am facing an issue, I am able to deploy my backend successfully. but after like 5 mins of inactivity, the URL loads forever. When that happens, I have to redeploy that specific commit, and then it works. this is a very frustrating situation. Can anyone help me, is it only me?

I’m facing the exact same issue. Just migrated from Heroku, Python 3 app. Everything works at first, but after it goes to sleep, the app never comes back. The request keeps going forever. Logs show nothing. Adding the health check path thing didn’t help. It checks once after deployment, says it’s ok, and that’s it. Apparently there’s no option to restart the app without redeploying the whole thing too. I could live with the surprisingly slow deployment times, but not if I have to do it all the time.

Same issue with me. If anyone finds a solution, please inform me.

Having the same issue after migrating from heroku server. Tried diagnosing both from application POV and server side but to no avail found anything worthwhile.

I saw Oregon mentioned in another thread reporting something similar, so I deleted the web service and redeployed to Ohio. So far, so good. The app’s been to sleep and back, it just took a minute to cold start. If the issue’s not resolved soon, it might be a good idea to check if it’s only affecting Oregon.

1 Like

Having the same issue. Hopefully Render will fix it themselves.
I have a Python 3 app, which I migrated from Heroku, and it has been working fine for the past few weeks. It started not responding a few hours ago. Gets temporarily fixed on redeployment, but then goes back down.

This might be the solution cause I have Oregon as my region, How can I change this? It seems like it’s disabled

I’m from Poland, I don’t know even where to check region… I don’t remember If I set region during registration… Also I have “never ending loading” problem… :frowning:

10 hours of down time and no response?

To make matters worse, whatever the situation is that we are all experiencing doesn’t seem to be shown on the status page: https://status.render.com/

1 Like

Hi, few answers earlier is solution. You need to delete service and create new one. I’m doing it now. I’ll use Frankfurt, and I’ll tell you if it works :slight_smile:

Yup.I have this Same situation
Have to Redeploy app after few minutes of Inactivity . This is Frustrating
Guys at Render please look into this situation
Will now have to delete my current deployed web service and try using another region Besides ‘Oregon’

1 Like

Same problem. I thought it was just me.

You set it when you create new web service and select region From a Dropdown

I know it now, as you can see on my later answers :wink: But thanks.
Frankfurt region has the same problem!:confused:

or maybe not (it’s working…) … I don’t know what’s happening… :confused: Maybe someone know better deployment? (free)

Changing Regions

We don’t support changing a service or database’s region at this time. You can always create a new service or database in your desired region.

Good to know, but I don’t think creating a new service is acceptable as a solution - since the same thing could happen tomorrow for the Ohio region.

I choose Frankfurt :wink: But I understand your point… For now, I didn’t find a better solution/deployment :confused:

1 Like

You can´t. When you select on register, you can´t change anymore. I think that it’s a flaw for their system.

Having the same problem with Oregon: node service sleeps, but doesn’t spin up again. Sometimes works, but most of the time not.

No official response yet?

you can change region by delete project and take new deploy, read earlier comments :wink: