How to change a service's Github repo?

I moved a service’s Github repo to a new Github organization, and now my service cannot deploy. I don’t see an option to update the Github repo name in the settings panel anywhere though.

Anybody know how this can be fixed?


So I tried installing Render as an app on Github and giving it access to the right repos in my Org, but still can’t seem to deploy due to access issues.

It seems deploys do happen successfully if triggered from a push to my main branch though, I just can’t trigger deploys manually.

Hi @aroc ,

I took a look at your services, and couldn’t find any issue with manual deployment. I also triggered a manual deploy myself of what I believe was the repo you were working on, and the manual deploy worked correctly.

If you’re still experiencing trouble, can you provide more detail about what exactly you’re seeing? Can you provide the Dashboard URL for the service that is not working correctly (e.g.

Hi Dan, this looks fixed. Maybe Render just needed a moment to resolve the change of ownership on Github? Or Github needed time to process something. Either way, it’s working now.

Thanks for you help!