Docker deployment failed

Hiiii There :wave:

i tried to deploy docker (os : linux) as a webservice. After sometime it failed with “Timeout” without any log information. I want docker environment in render.
i used docker in docker (docker pull docker:latest) image from dockerhub.
i just want to know is this a bug or i deployed in wrong way. If i am wrong please let me know the right way of deploying docker in render.
Thank you.

Hi there,

If I understand you correctly, it sounds like you’re trying to deploy Docker to run on us via our Docker environment - is that really what you want?

Take for instance running Wordpress on us, an example is provided at https://render.com/docs/deploy-wordpress and the Dockerfile that is used is the Wordpress docker image https://github.com/render-examples/wordpress/blob/master/Dockerfile

Let me know and we can help to get you straightened out here

John B

hii @John_B
Thank you for your reply and i think you understand well i want my docker envinorment where i can run my docker commands and pull other docker images this is [my repo] used in deployement and [docker image] i used
i tried to deploy but i got timeout error after log info " Pushing image to registry… DONE"
problem still continues let me know the way how can i deploy docker env
Thank You

That’s not going to be possible on Render, we don’t allow --privileged which is required for Docker in Docker to work.

John B