Deploys failing without logs

Hi so I don’t know what the reason behind this mess is but take a look at this - NestJs won't deploy - #5 by John_B

My service is hosted in the Frankfurt region. Tried recreating the service in the Singapore region and it worked. This could be an issue with Frankfurt.

I’m getting 500 {"message":"internal server error"} when deploying with the API

  api_key = Rails.application.credentials.render_api_key
  url = "{service_id}/deploys"

  response =, {}, {
    accept: :json,
    Authorization: "Bearer #{api_key}"

Just tried a deployment on Singapore and that works fine. Seems like problem is most likely just the Frankfurt region at the moment.

I don’t think changing the deployment to Singapore is a solution.

Also, I don’t understand how after 3 days no one from Render support has said nothing …

Hi. The Frankfurt region issue seems to be fixed as well. It works for me now.

Hi. I got the same issue in the Frankfurt region

Also facing the same issue. Trying to push a small change I made on my GitHub repo and it constantly is getting failed even though the logs say “Build Successful”. Just switched over from Heroku for a school project cause I need a free space to host a project and this has been pretty frustrating to try and get working for the past few days.

Ramon, the original poster of this thread (who we’ve been talking with on another ticket) mentioned that we hadn’t posted anything here about what’s going on - quite right to call us out. Thank you.

We’ve been dealing with this since over the weekend now and blank logs continue to plague us across services. We have a new reworked logging solution waiting to replace the present one which will be much more reliable and robust but at the moment we’re fighting fires with the old one.

Right now, we’re fully aware of the issue and are working as hard as we can to resolve it - failed deploys without logs are absolutely terrible!

Thank you for your patience here!

John B

1 Like

Just an update here to close this one out - we applied a fix last week and have been closely monitoring across the weekend and now consider this resolved. Any repeat cases then please contact us via

John B

Hey @John_B thanks for the update!

Sadly, I am not facing Deployment fails and the logs don’t show the entire process.

Any idea on how to solve this? :smile:

1 Like

Thanks for the thread! I’m also deploying my django app in the Singapore region, but the deploy fails and logs are blank too today!

Also, on the bright side the postgres instance has logs and deploys successfully.

Saw on Render Status - Issues with Logstreams that the issue has been resolved 17 hours ago, but I am still facing it.

** Also wanna say that I love your product, and it would be absolutely great If it worked as intended.

1 Like

Would also like to add that I’m experiencing this while trying to deploy a Django app in US-East as well.

1 Like

I’m having the same issue. No logs generated for build failures.

Im having the same issue with static sites

I am having the same issue trying to deploy a Ruby on Rails site.

I am having the same issue, trying to deploy a Nest.JS app on Oregon (US West). No log is printed and the deployment also fails, like Andrew_Ng rightly stated, the postgres instance works fine.

Having the same problem. The logs are very inconsistent, sometimes delayed, sometimes frozen, sometimes not showing up at all.

The browser console reports:

Hi there! You’re looking at Render version c1099a386.

Logs for web services and workers show a spinner which disappears after a few seconds and no logs show up. Logs for the Postgres service work fine, on the other hand.

There are no erroneous or blocked requests showing up in the network panel while looking at the logs view.

@markV @jnns This should all be resolved - dealt with in Render Status - Missing logs