Deployment ERRrrrrror

i was trying to deploy my ruby on rails app to render but i came across this error:

Bundle complete! 14 Gemfile dependencies, 68 gems now installed.

Apr 16 03:04:59 PMGems in the groups ‘development’ and ‘test’ were not installed.

Apr 16 03:04:59 PMBundled gems are installed into /opt/render/project/.gems

Apr 16 03:05:01 PMbash: ./bin/rails: Permission denied

Apr 16 03:05:01 PM==> Build failed :disappointed:

Apr 16 03:05:01 PM==> Common ways to troubleshoot your deploy: Troubleshooting Your Deploy | Render Docs

Hi there,

If you change references from /bin/rails to bundle exec rails then your issue will be resolved, see our Rails guide at https://docs.render.com/deploy-rails

Regards,

John B
Render Support, UTC+1 :uk:

It worked, thank you so much.

Great, thanks for confirming.

John B
Render Support, UTC+1 :uk:

I am also encountering the same issue, I tried this, but it still didn’t work


, here’s a screenshot of how I tried it out.

Hello Othniel

Try replacing bundle exec rails with ./bin/rails server

Please refer to the documentation and make that you have put the right command properties