Deploy Persistent Redis with Docker Failing

The current documentation and repo for deploying a redis instance just outright fails with no descriptive log errors to understand why. The image below shows the final output log and the render UI displays a “Failed” badge for the given deployment. I have tried both cloning the repo and just using the render-examples repo with no luck. This of course fails when using a render.yaml file too if you try and follow the manual deployment method.

This usually happens if there’s some very fast termination after starting the service up. Since this is Redis, it could be that it needs a disk for storing data. I was able to more or less reproduce the issue when I created a Redis service using GitHub - render-examples/redis: Persistent Redis as a private Docker service on Render without a disk. Using the render.yaml from the repo worked, however. Could you give a bit more detail on how you had it set up?

I have tried creating a redis instance using the render dashboard UI and also through a YAML config but both seem to fail with the same stall/error situation. The image below shows the current config I have for creating the redis instance. I also verified that the disk instance are created too.

I’ll use that block and give it a few goes.

I wasn’t able to reproduce it on our test accounts, but I did some digging around and it looks like there was some misconfiguration of your account on our end. I’ve patched that up and started an investigation as to how that happened. You should be good to go though.

1 Like

Thanks heaps for the support Adrian, much appreciated! I will try it again later to see if its resolved!