Deploy Logs Not Showing Failure (NodeJS)


I just signed up for render, yesterday, to try it out and deploy my NestJS webservice. I ran into some weird issue that was resolved by re-running the build, after clearing the cache. However, I wanted to write this to follow up to ensure I understand why this happened and what to expect moving forward.

Here is a screenshot of the logs:

Notice, the failed status, but no more output from the logs.

The build setup is a straightforward node/nestjs setup where I run the nest build command and then the start:prod command, which runs node dist/main internally.

As mentioned at the start, re-running and clearing the cache seemed to have fix the issue.

I also did some digging around the community and noticed this link: Deploy failed (but no logs). This is what triggered me to restart the build.

But again, just want to make sure I understand what’s going on.

Let me know if there’s any additional info, like build ID or something of that nature that I can share to help debug.

Thanks ahead of time!


Hi Bryan,

Thanks for reaching out.

Are you still seeing this behavior?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.