CREATE SERVER for POSTGRES_DFW failing because of permissions

Hi! I am on the edge of my technical literacy and could use some advice on an error while setting up a foreign data wrapper. I have two PG instances, both hosted on Render, both v13.

As the master user created by Render on the local db, I am able to run the extension creation successfully:
CREATE EXTENSION postgres_dfw;

However, when I try to run the following, I get an error:

CREATE SERVER tex_admin_replica_bridge
	FOREIGN DATA WRAPPER postgres_fdw
    OPTIONS (host '[remotexxxx].replica-cyan.oregon-postgres.render.com', port '5432', dbname '[remote_dbname]');

error message: ERROR: permission denied for foreign-data wrapper postgres_fdw

I’ve been googling and still am not unsure if I have a permissions issue I need to resolve first. I’m using the master user created for me by Render, but I also am led to believe that this master user is not a super user. I also tried using a host specification internal to Render but I get the same result.

Am I supposed to be able to do this on Render’s hosted db’s? I would appreciate nudging in the right direction thanks!

Hi Anthony,

Unfortunately Foreign Data Wrappers are not supported today. There is an existing feature request for this at https://feedback.render.com/features/p/foreign-data-wrappers.

I’d encourage you to add your voice to that discussion. It’s always useful to include as much information about your use case as possible for context.

Regards,

Matt

1 Like