Consistent internal network hostname resolution problems

This has happened several times. One server needs to access a resource on host:port on the internal network via the internal hostname. It cannot. But if I use the ip address of the other server and the port it works. Clearly a hostname resolution problem. Please fix. I know I can contact support but it takes hours to respond and fixing the problem once, it just reoccurs when I deploy another environment like staging or production of my set of services.

Update: this seems to be an open issue with the network not respecting the attached ports and using the default port of 10000. This is a go container. I will probably change the read port to the default and finding out if there’s another default port for the write port.

Responded via chat, but wanted to close the loop here in case anyone comes across this. It seems the issue was that the service was not available at the host:port address displayed in the internal address. It was however available at the default port host:10000. We are currently working on a fix for this so that services are reachable internally via any open port.

Jade worked on this with me quite quickly, and let me know today that a fix was in place. It worked. Everything is all set.
Thanks Jade!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.