Builds keep timing out

My builds keep timing out at this step for some reason. I haven’t changed my build script in months. I have tried manually setting a PORT env var to 10000 but nothing has changed. I’ve not touched any settings lately and have tried rolling back to previous working commits but nothing has worked.

I’m running Ruby 3 and Rails 7 and the error I’m getting is at this stage. The build eventually fails after 5 mins of hanging. Any ideas?

[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...
==> Build failed 😞
==> Common ways to troubleshoot your deploy:

I see that you’ve already initiated a support ticket with us. To avoid any confusion or duplicate efforts, let’s continue the conversation there

Render Support, UTC+3

Hi Jeremy, thanks for responding. Happy to continue the conversation there. Let me know if you need anything further from me. I’m waiting on your response.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.