You must install or update .NET to run this application

Full log:
https://termbin.com/b4sg

I just signed up and am testing out render.com. So far things have gone really smoothly apart from this. Am I right in understanding that the log says I have to upgrade to dotnet 7.0?

Hey there,
That looks like a Docker build so anything that is doing is unrelated to us I’m afraid as it’s not something we (Render) can support.

It should result in the same locally so you could try it there?

John B

Locally it builds and runs fine. I am pretty new to docker so I will read up a bit.

Edit: Is it possible for me to build the image locally and push it to render directly?

solved Problem deploying dotnet to render.com - #3 by duncan1 - Community - Docker Community Forums
Still not sure why it ran for me locally without getting that error but it works now.