Why i have to downgrade many of my requirements?

Hi, I when I click deploy, Render is asking me to downgrade many of my requirements. Why is this? for ex:

Jul 12 04:36:28 PM  ERROR: Could not find a version that satisfies the requirement datashape==0.5.4 (from versions: 0.3.0, 0.3.1, 0.4.0, 0.4.2, 0.4.3, 0.4.4, 0.4.5, 0.4.6, 0.4.7, 0.5.0, 0.5.1, 0.5.2)
Jul 12 04:36:28 PM  ERROR: No matching distribution found for datashape==0.5.4
Jul 12 04:36:28 PM  ==> Build failed 😞

I have several packages to change. What should I do here? Also is this possibly because of python version conflict? Mine is 3.10. What is default python Render uses?


It looks like your code may be trying to reference a path that exists on your local machine, but not on Render.

It seems you’ve edited the post significantly, from the original.

This issue is likely Python version related. The deploy logs show the Python version being used and link to the docs to set it to match the version you developed/tested on:

==> Using Python version 3.7.10 (default)
==> Docs on specifying a Python version: https://render.com/docs/python-version


Yeah sorry. Now changing the python version helped. thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.