Web Service Deployment Error

Hi!
I m trying to deploy a web service project, but I got this error. How can I solve this, any idea?

Successfully installed Pillow-10.2.0 certifi-2024.2.2 cffi-1.16.0 chardet-4.0.0 charset_normalizer-2.1.1 cryptography-42.0.2 gunicorn-21.2.0 idna-3.6 packaging-23.2 pdfminer.six-20221105 pdfplumber-0.10.3 pip-24.0 pycparser-2.21 pypdfium2-4.26.0 requests-2.31.0 schedule-1.2.1 urllib3-1.26.18

Feb 6 12:13:00 AM==> Uploading build…

Feb 6 12:13:08 AM==> Build uploaded in 7s

Feb 6 12:13:08 AM==> Build successful :tada:

Feb 6 12:13:11 AM==> Deploying…

==> Using Node version 20.10.0 (default)

==> Docs on specifying a Node version: Setting Your Node.js Version | Render Docs

==> Running ‘gunicorn gunlukresmigazete.wsgi:app’

==> No open HTTP ports detected

==> Web Services | Render Docs

The two most likely issues are either that (1) it’s binding on 127.0.0.1 instead of 0.0.0.0 (or *). Or (2) the server is not actually starting, are there any logs after what you’ve pasted here?

I ve changed the start command as ‘gunicorn -b 127.0.0.1 gunlukresmigazete.wsgi:app’, nothing changed. I m sharing the logs below:

It trys to deploy long long time then time out error occurs.
Thanks for your reply in advance.

Successfully installed Pillow-10.2.0 certifi-2024.2.2 cffi-1.16.0 chardet-4.0.0 charset_normalizer-2.1.1 cryptography-42.0.2 gunicorn-21.2.0 idna-3.6 packaging-23.2 pdfminer.six-20221105 pdfplumber-0.10.3 pip-24.0 pycparser-2.21 pypdfium2-4.26.0 requests-2.31.0 schedule-1.2.1 urllib3-1.26.18

Feb 6 10:19:53 PM==> Uploading build…

Feb 6 10:20:01 PM==> Build uploaded in 7s

Feb 6 10:20:01 PM==> Build successful :tada:

Feb 6 10:20:03 PM==> Deploying…

Feb 6 10:20:22 PM==> Using Node version 20.10.0 (default)

Feb 6 10:20:22 PM==> Docs on specifying a Node version: Setting Your Node.js Version | Render Docs

Feb 6 10:20:30 PM==> Running ‘gunicorn -b 127.0.0.1 gunlukresmigazete.wsgi:app’

Feb 6 10:23:48 PM==> No open HTTP ports detected

Feb 6 10:23:48 PM==> Web Services | Render Docs

Change it to -b 0.0.0.0.

gunicorn -b 0.0.0.0 gunlukresmigazete.wsgi:app unfortunately doesnt work

This application is either not appropriately listening on a port, or not listening at all. Can you share relevant code that sets up the web socket listening?